Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Tech Tip: False 50.2 error on LaserJet CP3505, only on envelopes

  1. #1

    Thumbs up Tech Tip: False 50.2 error on LaserJet CP3505, only on envelopes

    Hey techs, this is a strange issue that is just getting known, wanted you to be aware ...

    The new Color LaserJet CP3505 (similar to the Color LaserJet 3000, 3600, 3800 series) has a firmware bug which can trigger a False "50.2 Fuser Error" when printing envelopes...

    If a user gets a steady "50.2 Fuser Error" when trying to print envelopes from the MP tray (envelopes only, not regular paper) -- you should upgrade to the latest firmware ... replacing the fuser will not help :-)

  2. #2


    I purchased the hp cp3505dn back in early 2008 as part of the hp trade-in programme, and I have been dogged by the "50.2 Fuser Error" problem ever since. Specifically, when printing an envelope when the printer is in "sleep mode", the printer receives the print job, wakes up, displays "Processing..." and about 90 to 120 seconds later displays the message "50.2 fuser error".

    The message appears regardless of firmware version, and was still happening with the latest cp3505 firmware as of July 2009 (CLJCP3505fw_win_03_021_2.exe 20090604 03.021.2).

    After 2 other unrelated calls to hp during the past year for the cp3505dn, I finally raised a call regarding this problem. The solution recommended by the hp call center chap was to change the printer wake-up mode from "save energy" to "faster first page". I even had an hp subcontracted engineer come in and a) confirm the latest firmware and b) change the setting for me.

    This appears to have fixed the "50.2 fuser error" when printing envelopes from sleep mode. If it occurs again after making this change, I will update this thread accordingly.

    The engineer was on the phone with hp when on site said to me after the call that hp has an internal white paper regarding this issue, which suggests that it is common. I have found at least one other thread about the same issue (and will cross-post this to it). Hope this helps.

    - cormandy

  3. #3


    Ops! I spoke/wrote too soon!

    After changing the setting to "FASTER FIRST PAGE" the "50.2 fuser error" occurred again!

    Interestingly, if the printer recently entered sleep mode (e.g. within 5 minutes), it will sucessfully print an envelope upon waking from sleep mode. However, if the printer has been asleep for at least an hour, it will not print and instead report the "50.2 fuser error".

    I just got off the phone with hp, who have decided to replace the fuser. A new fuser will be posted to me, but as suggested at the top of this thread, it may not resolve the issue.

    Will update the thread once I install the new fuser and test.

  4. #4


    I would suggest upgrading the firmware again --> The firmware upgrade might not have "took". Upgrading the firmware can be tricky even for experienced computer techs as it is not always an "intuitive" process ... there are several ways you can upgrade the firmware: through a DOS command prompt, through FTP, or through the JetDirect interface in a browser window ... if the firmware upgrade doesn't take one way, you might have to try it another way ...

    You can print a Configuration page from the Information menu, and that printout will list your current Firmware version.

    I would suggest having someone who is extremely familiar with upgrading firmware try once again, as that seems to be where the issue stems from. HP tech support doesn't always know what they're dealing with :-)

  5. #5
    Join Date
    Jan 2005
    Elk Grove, California


    It's the DC Controller firmware that has to be at 37 or above.

    What happens is the printer starts to process the job, after powering up from a deep sleep, but the DCC firmware is not able to send the request to the LVPS in time to warm up the fuser. 50.2 is displayed indicating that the fuser hasn't reached operating temperature.

  6. #6


    Got it. There is more than one "firmware" update for the printer.

    This explains the confusion experienced when dealing with hp.

    Last weekend I logged a call online with hp regarding the problem. I received a call at the beginning of the week from the hp call centre; however, I had a hell of a time trying to understand the caller as his english was very poor. He mentioned the firmware update, and I explained that I had applied the latest firmware that was available from the hp website. He then tried to explain that there was some "other firmware" to apply, and that he would schedule a technican to visit and apply the firmware.

    After a wednesday no-show, the technician showed up on thursday and confirmed the latest firmware was applied. He then contacted hp and inquired why he even needed to come onsite. There was no mention of the "DC firmware update". The engineer changed the "optimum speed/energy usage" from "save energy" to ""faster first page" and left to his next appointment; and I beleive he felt that his time was wasted (no my problem).

    I let the printer sleep for awhile (1 hour) and sure enough the "50.2 fuser error" problem happened again. I opened a new call with hp, and after what seemed like an hour on the phone screwing about, the chap from the call centre (same country, better english) concluded that the fuser needed to be replaced.

    A new fuser was couriered out and I installed it last night (Friday). I have since changed the "optimum speed/energy usage" back to "save energy" and let the printer sleep for over an hour. I was able to successfully print a DL envelope from "sleep mode" without seeing the "50.2 fuser error".

    Printer info Firmware: 20090604 03.021.2

    I am disappointed that this "DC firmware controller update" was somehow missed.

    Is there any way that I can get the latest DC firmware for the cp3505dn and install myself? Although the problem has not occured, if it is indeed firmware related, I would prefer to have an up-to-date printer!

    - cormandy

  7. #7



    I've had a closer look as the Configuration dump, and even though the Frimware and JetDirect firmware are reporting the expected revision level that is expected with version "03.021.2 (6 Jun 2009)" of the firmware update, the DC Controller is reporting "34".

    This is what is HP have included in version "03.021.2 (6 Jun 2009)" for the cp3505:

    HP LJ CP3225 (Datecode: 20090604 03.021.2)
    DC Controller: R1.52.0
    Embedded JetDirect: V.34.63.FF

    Will attempt to re-apply...

  8. #8


    I have applied the firmware update many times, and in different fashions, including FTPing, using the windows update utility and the printer's web interface (file upload), however the "DC Controller" value remains at 34. Should I expect this value to change with the application of the firmware? The firmware readme or the cp3505 indicates a "DC Controller Frimware version of R1.52.0".

    Aside from the "DC Controller: 34" in the printed configuration, is there any way to determine the exact DC controller firmware version installed? Downloading the service manuals for the cp3505 now...

  9. #9
    Join Date
    Jan 2005
    Elk Grove, California


    I did some checking and the firmware upgrade that you installed included the DC Controller.
    Everything that I found shows that the "DC Controller: R1.52.0" is up to date.

    When I power up my other computer, I'll recheck that note for the known problem again.

    You did good.

  10. #10


    cs_steve: as Phil Hartman would say when playing Ed Mcmahon on SNL in the earlier '90s: "You are correct sir!" (May god rest their souls...)

    And to paraphrase a line from the the opening scene of the movie Poltergeist: "it's back!"

    The "50.2 Fuser Error" has reappeared when printing an envelope when waking from sleep. This time I left the printer in sleep mode all night and tried printing an envelope in the morning, and sure as eggs is eggs, the envelope failed to print and the "50.2 error message" appeared using the new fuser.

    I’m going to raise another call with HP. Heck, I’m going to get my money out of this Care Pack! Will follow up with this thread, and if anyone has any insights into the “DC Controller” firmware issue (e.g. how to verify the version, is it possible to patch separately, etc...) please post.

    - cormandy


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts