Results 1 to 3 of 3

Thread: Dell All-In-One 810 Printer Problems

  1. #1

    Default Dell All-In-One 810 Printer Problems

    I recently aquired a Dell AIO 810 Printer. After setting everything and powering it up, the Printer seems to get stuck. The main Power LED just blinks and I can't do anything about it, the only way to stop it blinking is to remove the power supply. I think it could be the power supply but I'm wondering if anyone else has had this problem in the past and if anyone could help I would be much obliged. I've tried contacting Dell but they are infuriatingly slow and have not got back to me on the problem, the manual offers no help either.

  2. #2
    Join Date
    Jul 2004
    Location
    Simi, Ca.
    Posts
    725

    Default Dell! Ha!

    First, Dell does not "make" the printer. It is probably a lexmark or canon.
    Second, Dell "sells" stuff, and "support" seems to be altered state for them!
    If the power button does not turn off the unit, then the power supply is bad.
    Hold the power button down when pluggin it in, for the count of nine, and let go. If it does not cycle up to ready in about 30 seconds, lift open the cover and check the inks. Replace if not new.
    Did you "aquire" this new, or used? If new, take it back to your vendor for a replacement.

  3. #3

    Default

    Quote Originally Posted by MichaelTech View Post
    First, Dell does not "make" the printer. It is probably a lexmark or canon.
    Second, Dell "sells" stuff, and "support" seems to be altered state for them!
    If the power button does not turn off the unit, then the power supply is bad.
    Hold the power button down when pluggin it in, for the count of nine, and let go. If it does not cycle up to ready in about 30 seconds, lift open the cover and check the inks. Replace if not new.
    Did you "aquire" this new, or used? If new, take it back to your vendor for a replacement.
    Well, I did as you said but it doesn't seem to want to cycle up, it just sits there and the Power LED blinks at me.

    The printer was "aquired" through a friend (whos printer it was orginally, before having it replaced and passing it on to me) and as such I believe the warranty is void. It would be nice if there was a way to get the thing working.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •